0
$\begingroup$

I'm trying to annotate images with COCO key points for pose estimation using https://github.com/jsbroks/coco-annotator. As described in the Installation section I cloned the repo. I installed Docker and Docker-compose. Following this I started the container with $ docker-compose up and it is running.

I am now on the website https://annotator.justinbrooks.ca/, I created one user and datasets but they do not appear in the repo datasets/ folder. I tried to create them manually and to load images in them but they do not appear on the website graphic interface.

I tried to scan, reload the webpage, create other datasets but it does not work. The container seems to work properly, it detects when I put an image in the datasets/ folder but it throws some errors.

Here is the last lines (I can post the whole log):

annotator_webclient | [File Watcher] File /datasets/haricot.jpg for created
annotator_webclient | [File Watcher] Adding new file to database: /datasets/image
annotator_message_q | 2019-05-16 13:01:08.841 [error] <0.461.0> closing AMQP connection <0.461.0> (172.18.0.4:42614 -> 172.18.0.2:5672):
annotator_message_q | missed heartbeats from client, timeout: 60s

Am I missing something fundamental or there is a bug?

I'm using Safari on macOS and I also tried Firefox on Ubuntu 18. I'm not behind a proxy, but maybe some ports are not open or something like this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.