1
$\begingroup$

I am working on a Neural Network and have plotted the performance of my model. However the plots seem not to fit the "trends" (which help you identify the issue with your model) presented in this illustration.enter image description here

Here is the performance of my modelenter image description here The loss metric I used was Binary Cross Entropy (due to my problem being a binary classification task). Is my model over or under-fitting? and how can you tell?

$\endgroup$
4
  • $\begingroup$ What I find weird is that my Validation accuracy is so high, while the Test one is so low $\endgroup$ Apr 17 at 2:45
  • $\begingroup$ Something is wrong with your testing and validation sets. They are not representative of each other, because if they were they would get similar results (with the test set being slightly worse normally) $\endgroup$
    – Recessive
    Apr 17 at 3:48
  • 1
    $\begingroup$ Thanks, this may have been due to the fact that I have used SMOTE in order to do some data augmentation (that data made up 30% of my dataset) $\endgroup$ Apr 17 at 4:04
  • 1
    $\begingroup$ In that case I would guess your augmented data isn't representative, and the test set is indicating this. Either way, you can definitely narrow down the issue to whatever differences lie between the validation and test set. The network is learning fine and doesn't seem to be overfitting $\endgroup$
    – Recessive
    Apr 17 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.